Добро пожаловать.

(4212) 24-24-29
г. Хабаровск,
ул. Ким Ю Чена, д. 38,
оф. 203.
studio@khvweb.com
211-028-011
Рады видеть Вас в блоге нашей студии! Здесь мы копим нужную, а иногда просто интересную информацию о создании сайтов. Категории:
Статьи
Новости Интернета
Новости студии
Обзоры
Публикации


Профессиональное создание сайтов - разработка интранет сайта. Интранет - готовое решение.
Главная » Блог » Новости Интернета

В серверном интерпретаторе PHP найдена опасная уязвимость



ИТ-специалисты из компании Sucuri Security говорят об обнаружении уязвимости в серверном интерпретаторе популярного языка веб-программирования PHP, эксплуатируя которую атакующий может внедрить злонамеренный код на сайт. Речь идет о специальной конфигурационной директиве, предназначенной для обслуживания на выделенных и VPS-серверах. В Sucuri говорят, что им уже удалось на экспериментальном проекте внедрить злонамеренные iFrame в веб-страницы.

"Мы обнаружили, что целые серверы можно скомпрометировать, если в основной конфигурационный файл php.ini добавить директиву auto_append_file="OFF"", - говорят в компании. Согласно данным руководства PHP, директива auto_append_file уточняет имя обрабатываемого файла, включаемого в парсинг до начала основной обработки кода. Эта директива является общесерверным аналогом функции PHP require ().

Положение Off в ряде версий на самом деле интерпретируется как файл /tmp/Off, который хакер может создать и внедрить туда злонамеренный код, вызываемый сервером. В компании Sucuri говорят, что в теории этой уязвимости может быть подвержено несколько десятков тысяч серверов, работающих в данный момент в интернете. "Мы уже получили отклик по данному сценарию от нескольких десятков серверов", - говорит Девид Деде, специалист по сетевой безопасности Sucuri.

По его словам, сейчас они исследовали данную уязвимость только на примере VPS и выделенных серверов, но при некоторой сноровке ее также можно применять и к серверам, обслуживающим системы разделяемого (Shared) хостинга.

В компании Websence говорят, что им также удалось подтвердить указанную уязвимость и в теории хакеры ей могут пользоваться уже несколько месяцев, хотя крупных атак с использованием данного сценария пока не было зафиксировано.

Подробные технические данные об уязвимости доступны здесь.


Теги: PHP

Комментарии